> CVE-2026-7860 [LOW]

« BACK_TO_HOME
PUBLISHED
2026-05-19 12:16
MODIFIED
2026-05-19 12:16
CVSS_SCORE V3
1.6
EPSS (Prob. Exploit)
0.13%
Top 97.5%
DATA SOURCES:
NVD 🔗 2026-05-19 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-10-25 GITHUB 🔗 2026-10-29

> DESCRIPTION

A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of environment variables in build logs whenever the frontend build process exits with a non-zero status. Because the build environment may contain credentials supplied as secrets, any failed frontend build can expose those secrets in clear text in CI logs and archived build artifacts. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 23.0.0 - 23.6.9 Vaadin 24.0.0 - 24.10.3 Vaadin 25.0.0 - 25.1.4 Mitigation Upgrade to 23.6.10 Upgrade to 24.10.4 or newer Upgrade to 25.1.5 or newer Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, or 25 version. ArtifactsMaven coordinatesVulnerable versionsFixed versioncom.vaadin:flow-plugin-base23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-plugin-base24.0.0 - 24.10.3≥24.10.4com.vaadin:flow-plugin-base25.0.0 - 25.1.4≥25.1.5com.vaadin:flow-maven-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-maven-plugin24.0.0 - 24.10.3≥24.10.4com.vaadin:flow-maven-plugin25.0.0 - 25.1.4≥25.1.5com.vaadin:flow-gradle-plugin24.0.0 - 24.10.3≥24.10.4com.vaadin:flow-gradle-plugin25.0.0 - 25.1.4≥25.1.5

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:N/R:A/V:C/RE:L/U:Green

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:N/R:A/V:C/RE:L/U:Green
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Local (L)
Exploit nécessite un accès local au système
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
Unknown (P)
Interaction inconnue
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-209

> CWE DETAILED DESCRIPTIONS

CWE-209: Generation of Error Message Containing Sensitive Information - The product generates an error message that includes sensitive information about its environment, users, or associated data.

> GITHUB SECURITY ADVISORY

GHSA-j8mx-j73w-9mxw LOW

Vaadin Build Plugins is Affected by a Possible Information Disclosure Vulnerability

AFFECTED PACKAGES:
MAVEN / com.vaadin:flow-gradle-plugin
>= 25.1.0, < 25.1.5
Fixed in: 25.1.5
MAVEN / com.vaadin:flow-gradle-plugin
>= 25.0.0, < 25.0.11
Fixed in: 25.0.12
MAVEN / com.vaadin:flow-gradle-plugin
>= 24.10.0, < 24.10.4
Fixed in: 24.10.4
MAVEN / com.vaadin:flow-gradle-plugin
>= 24.0.0, < 24.9.17
Fixed in: 24.9.18
MAVEN / com.vaadin:flow-maven-plugin
>= 25.1.0, < 25.1.5
Fixed in: 25.1.5
MAVEN / com.vaadin:flow-maven-plugin
>= 25.0.0, < 25.0.11
Fixed in: 25.0.12
MAVEN / com.vaadin:flow-maven-plugin
>= 24.10.0, < 24.10.4
Fixed in: 24.10.4
MAVEN / com.vaadin:flow-maven-plugin
>= 24.0.0, < 24.9.17
Fixed in: 24.9.18
MAVEN / com.vaadin:flow-maven-plugin
>= 23.0.0, < 23.6.10
Fixed in: 23.6.11
MAVEN / com.vaadin:flow-plugins
>= 25.1.0, < 25.1.5
Fixed in: 25.1.5

> HISTORIQUE DES MODIFICATIONS

Première apparition
19/05/2026 12:16
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-209: Generation of Error Message Containing Sensitive Information - The product generates an error message that includes sensitive information about its environment, users, or associated data.
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://github.com/vaadin/flow/pull/24219
https://vaadin.com/security/cve-2026-7860
« BACK_TO_HOME