> CVE-2026-73489 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-08-13 22:17
MODIFIED
2026-08-13 22:17
CVSS_SCORE V3
4.3
EPSS (Prob. Exploit)
0.45%
Top 60.8%
DATA SOURCES:
NVD 🔗 2026-08-13 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-01 OSV 🔗 2026-10-26

> DESCRIPTION

Russh is a Rust SSH client & server library. Prior to 0.62.4, an authenticated SSH client can cause a denial of service by sending a pty-req channel request with more than 130 terminal-mode records. The parser in russh/src/server/encrypted.rs stores terminal modes in a fixed 130-entry [(Pty::TTY_OP_END, 0); 130] array but continues increasing the mode count, then constructs an out-of-bounds slice and panics before the application pty_request handler runs. The panic terminates the server session task without causing memory corruption. This issue is fixed in version 0.62.4.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EXPLOITABILITY
2.8
IMPACT
1.4

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-129

> CWE DETAILED DESCRIPTIONS

CWE-129: Improper Validation of Array Index - The product uses untrusted input when calculating or using an array index, but the product does not validate or incorrectly validates the index to ensure the index references a valid position within the array.

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records

AFFECTED PACKAGES:
Unknown / Unknown
84 versions affected
ALIASES:
GHSA-cqjc-rmpq-xprq

> HISTORIQUE DES MODIFICATIONS

Première apparition
13/08/2026 22:17
Source: NVD
📊 ENRICHISSEMENT 01/09/2026 06:02
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-129: Improper Validation of Array Index - The product uses untrusted input when calculating or using an array index, but the product does not validate or incorrectly validates the index to ensure ...
Total des modifications: 1 Dernière mise à jour: 2 months ago

> REFERENCES

https://github.com/Eugeny/russh/commit/8912512371820167a12a0a638bd666856ce458ad
https://github.com/Eugeny/russh/releases/tag/v0.62.4
https://github.com/Eugeny/russh/security/advisories/GHSA-cqjc-rmpq-xprq
« BACK_TO_HOME