> CVE-2026-73258 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-08-20 18:16
MODIFIED
2026-08-20 18:16
CVSS_SCORE V3
6.5
EPSS (Prob. Exploit)
0.46%
Top 61.7%
DATA SOURCES:
NVD đź”— 2026-08-20 CWE MITRE đź”— 2026-09-01 FIRST EPSS đź”— 2026-10-18 OSV đź”— 2026-10-26

> DESCRIPTION

Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EXPLOITABILITY
3.9
IMPACT
2.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
Low (L)
Modification limitée des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
Low
Modification limitée des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-697

> CWE DETAILED DESCRIPTIONS

CWE-697: Incorrect Comparison - The product compares two entities in a security-relevant context, but the comparison is incorrect.

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Mongoose: Multipart boundary/header scan logic error in mg_http_next_multipart

AFFECTED PACKAGES:
Unknown / Unknown
55 versions affected
ALIASES:
GHSA-cc55-8v3r-59p8

> HISTORIQUE DES MODIFICATIONS

Première apparition
20/08/2026 18:16
Source: NVD
📊 ENRICHISSEMENT 01/09/2026 06:02
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-697: Incorrect Comparison - The product compares two entities in a security-relevant context, but the comparison is incorrect.
Total des modifications: 1 Dernière mise à jour: 1 month ago

> REFERENCES

https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869...
https://github.com/cesanta/mongoose/pull/3611
https://github.com/cesanta/mongoose/releases/tag/7.22
https://github.com/cesanta/mongoose/security/advisories/GHSA-cc55-8v3r-59p8
« BACK_TO_HOME