> CVE-2026-7142 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-04-27 17:16
MODIFIED
2026-04-27 17:16
CVSS_SCORE V3
5.3
EPSS (Prob. Exploit)
0.22%
Top 88.1%
DATA SOURCES:
NVD đź”— 2026-04-27 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-08 GITHUB đź”— 2026-10-29 OSV đź”— 2026-11-02

> DESCRIPTION

A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
Low (L)
Modification limitée des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
Low
Modification limitée des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-266 CWE-285

> CWE DETAILED DESCRIPTIONS

CWE-266: Incorrect Privilege Assignment - A product incorrectly assigns a privilege to a particular actor, creating an unintended sphere of control for that actor. | CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.

> GITHUB SECURITY ADVISORY

GHSA-528h-pc64-c93x MODERATE

stream-json: pick/ignore/filter/replace filters are O(depth²) on nested input — small crafted JSON blocks the event loop for seconds→minutes (DoS)

AFFECTED PACKAGES:
NPM / stream-json
<= 3.4.0
Fixed in: 3.5.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Wooey API Endpoint scripts.py add_or_update_script improper authorization

AFFECTED PACKAGES:
Unknown / Unknown
8 versions affected
ALIASES:
GHSA-w65c-cmxj-qrhm, PYSEC-2026-3427

> HISTORIQUE DES MODIFICATIONS

Première apparition
27/04/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-266: Incorrect Privilege Assignment - A product incorrectly assigns a privilege to a particular actor, creating an unintended sphere of control for that actor. | CWE-285: Improper Authorization - ...
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/wooey/Wooey/
https://github.com/wooey/Wooey/commit/f7846fc0c323da8325422cab32623491757f1b88
https://github.com/wooey/Wooey/issues/408
https://github.com/wooey/Wooey/pull/407
https://github.com/wooey/Wooey/releases/tag/v0.13.3rc1
https://vuldb.com/submit/801533
https://vuldb.com/vuln/359741
https://vuldb.com/vuln/359741/cti
« BACK_TO_HOME