> CVE-2026-6739 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-06-12 17:16
MODIFIED
2026-06-12 17:16
CVSS_SCORE V3
6.7
EPSS (Prob. Exploit)
0.46%
Top 60.9%
DATA SOURCES:
NVD đź”— 2026-06-12 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-10-25 GITHUB đź”— 2026-10-29

> DESCRIPTION

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to require system-level permission when patching protected default system roles, which allows authenticated users with delegated user-management permissions to escalate privileges by altering built-in role permissions via the role patch API.. Mattermost Advisory ID: MMSA-2026-00656

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
EXPLOITABILITY
1.2
IMPACT
5.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
High (H)
Authentifié avec privilèges administratifs
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-863

> CWE DETAILED DESCRIPTIONS

CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.

> GITHUB SECURITY ADVISORY

GHSA-m2w9-h2mm-79qr MODERATE

Mattermost doesn't require system-level permission when patching protected default system roles

AFFECTED PACKAGES:
GO / github.com/mattermost/mattermost/server/v8
>= 8.0.0-20250731163400-5b955468ea1e, < 8.0.0-20260501142004-99b73d4c4acf
Fixed in: 8.0.0-20260501142004-99b73d4c4acf
GO / github.com/mattermost/mattermost-server
>= 10.11.0, <= 10.11.15
Fixed in: 10.11.17
GO / github.com/mattermost/mattermost-server
>= 11.5.0, <= 11.5.4
Fixed in: 11.5.5
GO / github.com/mattermost/mattermost-server
= 11.6.0
Fixed in: 11.6.1

> HISTORIQUE DES MODIFICATIONS

Première apparition
12/06/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/07/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Total des modifications: 1 Dernière mise à jour: 4 months ago

> REFERENCES

https://mattermost.com/security-updates
« BACK_TO_HOME