> CVE-2026-6228 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-05-15 09:16
MODIFIED
2026-05-15 09:16
CVSS_SCORE V3
8.8
EPSS (Prob. Exploit)
0.44%
Top 61.5%
DATA SOURCES:
NVD 🔗 2026-05-15 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-01 GITHUB 🔗 2026-11-05

> DESCRIPTION

The Frontend Admin by DynamiApps plugin for WordPress is vulnerable to Privilege Escalation in versions up to and including 3.28.36. This is due to insufficient authorization checks in the role field update mechanism combined with overly permissive capabilities for the admin_form post type. The admin_form custom post type uses 'capability_type' => 'page', which grants editors the ability to create and edit forms. When an editor creates an edit_user form, they can manipulate the form configuration to include 'administrator' in the role_options array by directly submitting POST data to wp-admin/post.php, bypassing the UI restrictions in feadmin_get_user_roles(). When the form is subsequently submitted, the pre_update_value() function in class-role.php only validates that the submitted role exists in the form's role_options array (lines 107-110), but fails to verify that the current user has permission to assign that specific role. This makes it possible for unauthenticated attackers to first register as editors (via a public new_user form), then create an edit_user form with administrator in the allowed roles, and finally use that form to escalate their own privileges to administrator.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EXPLOITABILITY
2.8
IMPACT
5.9

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-269

> CWE DETAILED DESCRIPTIONS

CWE-269: Improper Privilege Management - The product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.

> GITHUB SECURITY ADVISORY

GHSA-xcw9-qmmf-vqxj MODERATE

Dozzle label filters do not restrict container event and statistics streams

AFFECTED PACKAGES:
GO / github.com/amir20/dozzle
< 1.29.1-0.20260622172006-19c01e0fb491
Fixed in: 1.29.1-0.20260622172006-19c01e0fb491

> HISTORIQUE DES MODIFICATIONS

Première apparition
15/05/2026 09:16
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-269: Improper Privilege Management - The product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://plugins.trac.wordpress.org/browser/acf-frontend-form-element/trunk/main/...
https://plugins.trac.wordpress.org/browser/acf-frontend-form-element/trunk/main/...
https://plugins.trac.wordpress.org/browser/acf-frontend-form-element/trunk/main/...
https://plugins.trac.wordpress.org/changeset/3519460
https://www.wordfence.com/threat-intel/vulnerabilities/id/083accd0-8338-47c6-b39...
« BACK_TO_HOME