> CVE-2026-59965 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-09-15 16:17
MODIFIED
2026-09-15 16:17
CVSS_SCORE V3
7.1
EPSS (Prob. Exploit)
0.38%
Top 69.4%
DATA SOURCES:
NVD 🔗 2026-09-15 CWE MITRE 🔗 2026-10-01 FIRST EPSS 🔗 2026-10-25 GITHUB 🔗 2026-10-15 OSV 🔗 2026-09-22

> DESCRIPTION

Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
EXPLOITABILITY
2.8
IMPACT
4.2

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-863

> CWE DETAILED DESCRIPTIONS

CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.

> GITHUB SECURITY ADVISORY

GHSA-4qpv-39hg-f7fx HIGH

@jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission

AFFECTED PACKAGES:
NPM / @jhb.software/payload-alt-text-plugin
< 0.8.0
Fixed in: 0.8.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

@jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission

AFFECTED PACKAGES:
Unknown / Unknown
26 versions affected
ALIASES:
GHSA-4qpv-39hg-f7fx

> HISTORIQUE DES MODIFICATIONS

Première apparition
15/09/2026 16:17
Source: NVD
📊 ENRICHISSEMENT 01/10/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Total des modifications: 1 Dernière mise à jour: 3 weeks ago

> REFERENCES

https://github.com/jhb-software/payload-plugins/commit/e39634868ce13a414e2981e21...
https://github.com/jhb-software/payload-plugins/pull/159
https://github.com/jhb-software/payload-plugins/releases/tag/[email protected]
https://github.com/jhb-software/payload-plugins/security/advisories/GHSA-4qpv-39...
« BACK_TO_HOME