PUBLISHED
2026-08-10 11:17
MODIFIED
2026-08-10 11:17
EPSS (Prob. Exploit)
1.22%
Top 31.4%
> DESCRIPTION
Remote Code Execution Vulnerability in GraalScriptEngineCreator in Apache Ranger <= 2.8.0
Users are recommended to upgrade to version 2.9.0, which fixes this issue.
> AFFECTED_PRODUCTS
ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.
> CWE DETAILED DESCRIPTIONS
CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment.
> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)
Apache Ranger: Remote Code Execution Vulnerability in GraalScriptEngineCreator
AFFECTED PACKAGES:
Unknown / Unknown
34 versions affected
> HISTORIQUE DES MODIFICATIONS
Première apparition
10/08/2026 11:17
Source: NVD
📊
ENRICHISSEMENT
01/11/2026 06:59
CWE
Champ modifié: Description CWE
Ancienne valeur:
CWE-94: Improper Control of Generation of Code ('Code Injection') - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not n...
Nouvelle valeur:
CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorr...
📊
ENRICHISSEMENT
01/09/2026 06:02
CWE
Champ modifié: Description CWE
Nouvelle valeur:
CWE-94: Improper Control of Generation of Code ('Code Injection') - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not n...
Total des modifications: 2
Dernière mise à jour: 2 days ago