> CVE-2026-55435 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-07-07 19:16
MODIFIED
2026-07-07 19:16
CVSS_SCORE V3
5.4
EPSS (Prob. Exploit)
0.32%
Top 76.7%
DATA SOURCES:
NVD 🔗 2026-07-07 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-10-25 GITHUB 🔗 2026-11-05 OSV 🔗 2026-11-02

> DESCRIPTION

Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.30.0 and prior to versions 2.32.7, 2.33.8, and 2.34.2, AI Bridge proxy endpoints authenticate via `Server.IsAuthorized` in `coderd/aibridgedserver`, which validates key format, expiry, secret and deleted or system users but does not check whether the account is suspended. Because suspension does not revoke existing API keys, a suspended user's unexpired token keeps working. Practical impact is limited to already-issued API keys of suspended users until those keys are deleted. Versions 2.32.7, 2.33.8, and 2.34.2 patch the issue. As a workaround, on suspension, delete the user's API keys via `DELETE /api/v2/users/{user}/keys`.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EXPLOITABILITY
2.8
IMPACT
2.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
Low (L)
Modification limitée des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
Low
Modification limitée des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-863

> CWE DETAILED DESCRIPTIONS

CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.

> GITHUB SECURITY ADVISORY

GHSA-wqxv-w64v-5wh6 MODERATE

Suspended Coder users retain access to AI Bridge LLM proxy endpoints

AFFECTED PACKAGES:
GO / github.com/coder/coder/v2
>= 2.30.0, < 2.32.7
Fixed in: 2.32.7
GO / github.com/coder/coder/v2
>= 2.33.0, < 2.33.8
Fixed in: 2.33.8
GO / github.com/coder/coder/v2
>= 2.34.0, < 2.34.2
Fixed in: 2.34.2

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Suspended Coder users retain access to AI Bridge LLM proxy endpoints

AFFECTED PACKAGES:
Unknown / Unknown
10 versions affected
ALIASES:
GHSA-wqxv-w64v-5wh6, GO-2026-5925

> HISTORIQUE DES MODIFICATIONS

Première apparition
07/07/2026 19:16
Source: NVD
📊 ENRICHISSEMENT 01/08/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Total des modifications: 1 Dernière mise à jour: 3 months ago

> REFERENCES

https://github.com/coder/coder/commit/0d2c9f904a8b75b888140fcc8fbf4633660cc787
https://github.com/coder/coder/pull/26164
https://github.com/coder/coder/pull/26173
https://github.com/coder/coder/releases/tag/v2.32.7
https://github.com/coder/coder/releases/tag/v2.33.8
https://github.com/coder/coder/releases/tag/v2.34.2
https://github.com/coder/coder/security/advisories/GHSA-wqxv-w64v-5wh6
« BACK_TO_HOME