> CVE-2026-53587 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-08-20 19:16
MODIFIED
2026-08-20 19:16
CVSS_SCORE V3
7.5
EPSS (Prob. Exploit)
0.47%
Top 60.7%
DATA SOURCES:
NVD đź”— 2026-08-20 CWE MITRE đź”— 2026-09-01 FIRST EPSS đź”— 2026-10-18 OSV đź”— 2026-10-26

> DESCRIPTION

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, libgit2 performs a fixed-size strncmp in set_data in src/libgit2/transports/smart_pkt.c without first verifying that the smart-protocol pkt-line capability buffer contains 14 bytes. A malicious Git server can make bytes after the pkt-line complete object-format=, causing format_str to advance beyond the pkt-line and the following memchr length calculation to underflow. The resulting heap out-of-bounds walk can crash a client during the first refs-advertisement packet over HTTP, HTTPS, SSH, or the Git protocol. This issue is fixed in versions 1.8.6 and 1.9.5.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EXPLOITABILITY
3.9
IMPACT
3.6

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-20 CWE-125 CWE-126 CWE-1284

> CWE DETAILED DESCRIPTIONS

CWE-20: Improper Input Validation - The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly. | CWE-125: Out-of-bounds Read - The product reads data past the end, or before the beginning, of the intended buffer. | CWE-126: Buffer Over-read - The product reads from a buffer using buffer access mechanisms such as indexes or pointers that reference memory locations after the targeted buffer. | CWE-1284: Improper Validation of Specified Quantity in Input - The product receives input that is expected to specify a quantity (such as size or length), but it does not validate or incorrectly validates that the quantity has the required properties.

> RED HAT SECURITY ADVISORIES

Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update
An update for Red Hat Hardened Images RPMs is now available.
Red Hat Security Advisory: rust security update
An update for rust is now available for Red Hat Enterprise Linux 9. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVS...
Red Hat Security Advisory: rust security update
An update for rust is now available for Red Hat Enterprise Linux 10. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CV...
Red Hat Security Advisory: rust security update
An update for rust is now available for Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions. Red Hat Product Security has rated this update as having a security impact of Important. A Comm...
Red Hat Security Advisory: rust security update
An update for rust is now available for Red Hat Enterprise Linux 10.0 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulner...
Red Hat Security Advisory: rust security update
An update for rust is now available for Red Hat Enterprise Linux 9.6 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnera...

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

libgit2 - Unauthenticated network-reachable heap out-of-bounds read in transports/smart_pkt.c:set_data

AFFECTED PACKAGES:
Unknown / Unknown
52 versions affected
ALIASES:
GHSA-pm24-4jhq-3xvm

> HISTORIQUE DES MODIFICATIONS

Première apparition
20/08/2026 19:16
Source: NVD
📊 ENRICHISSEMENT 01/09/2026 06:02
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process...
Total des modifications: 1 Dernière mise à jour: 1 month ago

> REFERENCES

https://github.com/libgit2/libgit2/commit/2c0ce8c0132ac38ab0db28239462a671e2e544...
https://github.com/libgit2/libgit2/commit/affda60c10fcef16723451c0d7dc71b71dc20a...
https://github.com/libgit2/libgit2/commit/d7a9fb87f504434e9f45228678953c4fa56e76...
https://github.com/libgit2/libgit2/releases/tag/v1.8.6
https://github.com/libgit2/libgit2/releases/tag/v1.9.5
https://github.com/libgit2/libgit2/security/advisories/GHSA-pm24-4jhq-3xvm
« BACK_TO_HOME