> CVE-2026-49872 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-06-19 14:16
MODIFIED
2026-06-19 17:16
CVSS_SCORE V3
5.3
EPSS (Prob. Exploit)
0.53%
Top 55.4%
DATA SOURCES:
NVD 🔗 2026-06-19 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-01 OSV 🔗 2026-11-02

> DESCRIPTION

Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-287

> CWE DETAILED DESCRIPTIONS

CWE-287: Improper Authentication - When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Apache APISIX: Improper authentication in cas-auth plugin

AFFECTED PACKAGES:
Unknown / Unknown
ALIASES:
BIT-apisix-2026-49872

> HISTORIQUE DES MODIFICATIONS

Première apparition
19/06/2026 14:16
Source: NVD
📊 ENRICHISSEMENT 01/07/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-287: Improper Authentication - When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
Total des modifications: 1 Dernière mise à jour: 4 months ago

> REFERENCES

https://lists.apache.org/thread/bzjpo60ygxo7kxdqf7vw3l5zw2lh6m5k
http://www.openwall.com/lists/oss-security/2026/06/19/15
« BACK_TO_HOME