> CVE-2026-49270

« BACK_TO_HOME
PUBLISHED
2026-06-01 09:16
MODIFIED
2026-06-01 09:16
EPSS (Prob. Exploit)
0.37%
Top 69.2%
DATA SOURCES:
NVD 🔗 2026-06-01 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-01 GITHUB 🔗 2026-11-05 OSV 🔗 2026-11-02

> DESCRIPTION

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> WEAKNESSES

CWE-1230

> CWE DETAILED DESCRIPTIONS

CWE-1230: Exposure of Sensitive Information Through Metadata - The product prevents direct access to a resource containing sensitive information, but it does not sufficiently limit access to metadata that is derived from the original, sensitive information.

> GITHUB SECURITY ADVISORY

GHSA-hf52-78x8-6w3w MODERATE

Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability

AFFECTED PACKAGES:
MAVEN / org.apache.activemq:activemq-all
>= 6.0.0, < 6.2.6
Fixed in: 6.2.6
MAVEN / org.apache.activemq:activemq-all
< 5.19.7
Fixed in: 5.19.7
MAVEN / org.apache.activemq:activemq-broker
>= 6.0.0, < 6.2.6
Fixed in: 6.2.6
MAVEN / org.apache.activemq:activemq-broker
< 5.19.7
Fixed in: 5.19.7
MAVEN / org.apache.activemq:apache-activemq
>= 6.0.0, < 6.2.6
Fixed in: 6.2.6
MAVEN / org.apache.activemq:apache-activemq
< 5.19.7
Fixed in: 5.19.7

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Durable Subscription Disclosure via Crafted BrokerInfo (OpenWire)

AFFECTED PACKAGES:
Unknown / Unknown
24 versions affected
ALIASES:
BIT-activemq-2026-49270, GHSA-hf52-78x8-6w3w

> HISTORIQUE DES MODIFICATIONS

Première apparition
01/06/2026 09:16
Source: NVD
📊 ENRICHISSEMENT 01/07/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-1230: Exposure of Sensitive Information Through Metadata - The product prevents direct access to a resource containing sensitive information, but it does not sufficiently limit access to metadata ...
Total des modifications: 1 Dernière mise à jour: 4 months ago

> REFERENCES

https://lists.apache.org/thread/k3233c1x506z3w7x4z0dqvd86d4v2fr2
http://www.openwall.com/lists/oss-security/2026/05/31/22
« BACK_TO_HOME