> CVE-2026-49229 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-07-07 22:16
MODIFIED
2026-07-07 22:16
CVSS_SCORE V3
8.3
EPSS (Prob. Exploit)
0.32%
Top 74.9%
DATA SOURCES:
NVD 🔗 2026-07-07 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-01 GITHUB 🔗 2026-10-29 OSV 🔗 2026-11-02

> DESCRIPTION

Actual is a local-first personal finance app. Prior to 26.6.0, in OpenID multi-user mode, disabling a user only blocks future OpenID login for that identity, while existing Actual session tokens for the disabled user remain valid. The shared session validation path accepts any existing token row that has not expired without checking whether the associated user is still enabled, allowing a disabled user to continue calling authenticated server endpoints. This issue is fixed in version 26.6.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EXPLOITABILITY
2.8
IMPACT
5.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-613

> CWE DETAILED DESCRIPTIONS

CWE-613: DEPRECATED: Insufficient Session Expiration - This entry has been deprecated because it was insufficiently clear. Consider CWE-1462 and its descendants.

> GITHUB SECURITY ADVISORY

GHSA-cq9c-6w48-qmfg HIGH

@actual-app/sync-server: Disabled OpenID users keep access through existing session tokens

AFFECTED PACKAGES:
NPM / @actual-app/sync-server
<= 26.5.2
Fixed in: 26.6.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Actual: Disabled OpenID users keep access through existing session tokens

AFFECTED PACKAGES:
Unknown / Unknown
50 versions affected
ALIASES:
GHSA-cq9c-6w48-qmfg

> HISTORIQUE DES MODIFICATIONS

Première apparition
07/07/2026 22:16
Source: NVD
📊 ENRICHISSEMENT 01/11/2026 06:59
CWE
Champ modifié: Description CWE
Ancienne valeur:
CWE-613: Insufficient Session Expiration - According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization....
Nouvelle valeur:
CWE-613: DEPRECATED: Insufficient Session Expiration - This entry has been deprecated because it was insufficiently clear. Consider CWE-1462 and its descendants.
📊 ENRICHISSEMENT 01/08/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-613: Insufficient Session Expiration - According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization....
Total des modifications: 2 Dernière mise à jour: 5 days ago

> REFERENCES

https://github.com/actualbudget/actual/commit/c8cb8a223a4faf1c2e1dcb0795a79a93f7...
https://github.com/actualbudget/actual/releases/tag/v26.6.0
https://github.com/actualbudget/actual/security/advisories/GHSA-cq9c-6w48-qmfg
« BACK_TO_HOME