PUBLISHED
2026-07-06 11:16
MODIFIED
2026-07-06 11:16
EPSS (Prob. Exploit)
0.69%
Top 47.6%
> DESCRIPTION
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
> AFFECTED_PRODUCTS
ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.
> CWE DETAILED DESCRIPTIONS
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process the data safely and
correctly.
> GITHUB SECURITY ADVISORY
GHSA-hh8r-75r6-qrg9
HIGH
Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters
AFFECTED PACKAGES:
MAVEN / org.apache.camel:camel-spring-ai-tools
>= 4.19.0, < 4.21.0
Fixed in: 4.21.0
MAVEN / org.apache.camel:camel-spring-ai-tools
>= 4.8.0, < 4.18.3
Fixed in: 4.18.3
MAVEN / org.apache.camel:camel-langchain4j-agent
>= 4.19.0, < 4.21.0
Fixed in: 4.21.0
MAVEN / org.apache.camel:camel-langchain4j-agent
>= 4.8.0, < 4.18.3
Fixed in: 4.18.3
MAVEN / org.apache.camel:camel-langchain4j-tools
>= 4.19.0, < 4.21.0
Fixed in: 4.21.0
MAVEN / org.apache.camel:camel-langchain4j-tools
>= 4.8.0, < 4.18.3
Fixed in: 4.18.3
> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)
Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters
ALIASES:
GHSA-hh8r-75r6-qrg9
> HISTORIQUE DES MODIFICATIONS
Première apparition
06/07/2026 11:16
Source: NVD
📊
ENRICHISSEMENT
01/08/2026 06:01
CWE
Champ modifié: Description CWE
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process...
Total des modifications: 1
Dernière mise à jour: 3 months ago