> CVE-2026-48717 [CRITICAL]

« BACK_TO_HOME
PUBLISHED
2026-09-15 10:17
MODIFIED
2026-09-15 10:17
CVSS_SCORE V3
9.1
EPSS (Prob. Exploit)
0.53%
Top 56.0%
DATA SOURCES:
NVD đź”— 2026-09-15 CWE MITRE đź”— 2026-10-01 FIRST EPSS đź”— 2026-10-25 GITHUB đź”— 2026-10-15 OSV đź”— 2026-09-21

> DESCRIPTION

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-285

> CWE DETAILED DESCRIPTIONS

CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.

> GITHUB SECURITY ADVISORY

GHSA-4v2w-2wqp-mc85 MODERATE

OpenAM OAuth Authorization Bypass via PKCE Challenge

AFFECTED PACKAGES:
MAVEN / org.openidentityplatform.openam:openam-oauth2
<= 16.0.6
Fixed in: 16.1.1

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

OpenAM OAuth Authorization Bypass via PKCE Challenge

AFFECTED PACKAGES:
Unknown / Unknown
75 versions affected
ALIASES:
GHSA-4v2w-2wqp-mc85

> HISTORIQUE DES MODIFICATIONS

Première apparition
15/09/2026 10:17
Source: NVD
📊 ENRICHISSEMENT 01/10/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.
Total des modifications: 1 Dernière mise à jour: 3 weeks ago

> REFERENCES

https://github.com/OpenIdentityPlatform/OpenAM/commit/97a34d9fee17395e8e052bfc45...
https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1
https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-4v2w-2wq...
« BACK_TO_HOME