> CVE-2026-48089 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-06-19 20:16
MODIFIED
2026-06-19 20:16
CVSS_SCORE V3
7.1
EPSS (Prob. Exploit)
0.36%
Top 69.7%
DATA SOURCES:
NVD đź”— 2026-06-20 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

DevGuard provides vulnerability management for the full software supply chain. Prior to 1.4.2, on a DevGuard API instance with one or more public assets, any authenticated user — including users from a different organization with no membership or role in the affected org/project — can create, update, reapply, and delete VEX rules on those public assets. The same flaw affects the other vulnerability-triage write endpoints exposed under a public asset, including VEX rule create / update / reapply / delete; dependency-vuln event creation (accept / reject / mitigate decisions), batch event creation, vuln sync, and mitigation; license risk creation; external reference writes; and/or artifact creation and license refresh. The attacker needs a valid account on the instance, but no membership in the victim organization, project, or asset is required. Version `v1.4.2`contains a patch. As a workaround, make affected assets non-public. In the asset settings, switch visibility from public to private. This removes the public-read exemption in the access-control middleware and restores correct authorization on all write endpoints for that asset. Downstream consumers that previously relied on the public `vex.json` / `sbom.json` endpoints will need to be granted explicit access or must receive an exported file version until the patched release is deployed.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-285 CWE-863

> CWE DETAILED DESCRIPTIONS

CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action. | CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.

> GITHUB SECURITY ADVISORY

GHSA-6p54-fw2f-q7gf HIGH

DevGuard has improper authorization on public assets

AFFECTED PACKAGES:
GO / github.com/l3montree-dev/devguard
< 1.4.2
Fixed in: 1.4.2

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

DevGuard has improper authorization on public assets

AFFECTED PACKAGES:
Unknown / Unknown
151 versions affected
ALIASES:
GHSA-6p54-fw2f-q7gf, GO-2026-5183

> HISTORIQUE DES MODIFICATIONS

Première apparition
19/06/2026 20:16
Source: NVD
📊 ENRICHISSEMENT 01/07/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action. | CWE-863: Incorrect Aut...
Total des modifications: 1 Dernière mise à jour: 4 months ago

> REFERENCES

https://github.com/l3montree-dev/devguard/commit/1be88ec1309a5dc0566e35a23bdc4ea...
https://github.com/l3montree-dev/devguard/security/advisories/GHSA-6p54-fw2f-q7g...
« BACK_TO_HOME