> CVE-2026-48032 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-07-24 19:16
MODIFIED
2026-07-24 19:16
CVSS_SCORE V3
8.3
EPSS (Prob. Exploit)
0.54%
Top 54.7%
DATA SOURCES:
NVD đź”— 2026-07-24 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-10-29 OSV đź”— 2026-11-02

> DESCRIPTION

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-697

> CWE DETAILED DESCRIPTIONS

CWE-697: Incorrect Comparison - The product compares two entities in a security-relevant context, but the comparison is incorrect.

> GITHUB SECURITY ADVISORY

GHSA-g759-4pxw-6692 HIGH

@hulumi/policies bypasses IAM-role policy checks when the role trusts multiple OIDC providers

AFFECTED PACKAGES:
NPM / @hulumi/policies
< 1.4.0
Fixed in: 1.4.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Hulumi: IAM-role policy checks bypassed when the role trusts multiple OIDC providers

AFFECTED PACKAGES:
Unknown / Unknown
4 versions affected
ALIASES:
GHSA-g759-4pxw-6692

> HISTORIQUE DES MODIFICATIONS

Première apparition
24/07/2026 19:16
Source: NVD
📊 ENRICHISSEMENT 01/08/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-697: Incorrect Comparison - The product compares two entities in a security-relevant context, but the comparison is incorrect.
Total des modifications: 1 Dernière mise à jour: 3 months ago

> REFERENCES

https://github.com/kerberosmansour/hulumi/pull/178
https://github.com/kerberosmansour/hulumi/releases/tag/v1.4.0
https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-g759-4pxw-669...
« BACK_TO_HOME