PUBLISHED
2026-06-01 09:16
MODIFIED
2026-06-01 09:16
EPSS (Prob. Exploit)
0.35%
Top 71.5%
> DESCRIPTION
Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions.
This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.
Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.
> AFFECTED_PRODUCTS
ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.
> CWE DETAILED DESCRIPTIONS
CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.
> GITHUB SECURITY ADVISORY
GHSA-cpw7-g3p5-qrfq
MODERATE
Apache ActiveMQ server has an incomplete authorization workflow
AFFECTED PACKAGES:
MAVEN / org.apache.activemq:apache-activemq
>= 6.0.0, < 6.2.6
Fixed in: 6.2.6
MAVEN / org.apache.activemq:apache-activemq
< 5.19.7
Fixed in: 5.19.7
> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incomplete authorization during destination removal
AFFECTED PACKAGES:
Unknown / Unknown
24 versions affected
ALIASES:
BIT-activemq-2026-46605, GHSA-cpw7-g3p5-qrfq
> HISTORIQUE DES MODIFICATIONS
Première apparition
01/06/2026 09:16
Source: NVD
📊
ENRICHISSEMENT
01/07/2026 06:01
CWE
Champ modifié: Description CWE
Nouvelle valeur:
CWE-285: Improper Authorization - The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.
Total des modifications: 1
Dernière mise à jour: 4 months ago