PUBLISHED
2026-07-06 11:16
MODIFIED
2026-07-06 11:16
EPSS (Prob. Exploit)
0.69%
Top 47.6%
> DESCRIPTION
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
> AFFECTED_PRODUCTS
ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.
> CWE DETAILED DESCRIPTIONS
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process the data safely and
correctly.
> GITHUB SECURITY ADVISORY
GHSA-46jf-c9vx-hh79
HIGH
Apache Camel-Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
AFFECTED PACKAGES:
MAVEN / org.apache.camel:camel-couchbase
>= 4.19.0, < 4.21.0
Fixed in: 4.21.0
MAVEN / org.apache.camel:camel-couchbase
>= 4.15.0, < 4.18.3
Fixed in: 4.18.3
MAVEN / org.apache.camel:camel-couchbase
>= 4.0.0, < 4.14.8
Fixed in: 4.14.8
> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)
Apache Camel: Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
> HISTORIQUE DES MODIFICATIONS
Première apparition
06/07/2026 11:16
Source: NVD
📊
ENRICHISSEMENT
01/08/2026 06:01
CWE
Champ modifié: Description CWE
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process...
Total des modifications: 1
Dernière mise à jour: 3 months ago