> CVE-2026-44827 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-05-14 17:16
MODIFIED
2026-05-14 17:16
CVSS_SCORE V3
8.8
EPSS (Prob. Exploit)
0.72%
Top 46.1%
DATA SOURCES:
NVD 🔗 2026-05-14 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-01 GITHUB 🔗 2026-11-05 OSV 🔗 2026-11-02

> DESCRIPTION

Diffusers is the a library for pretrained diffusion models. Prior to 0.38.0, diffusers 0.37.0 allows remote code execution without the trust_remote_code=True safeguard when loading pipelines from Hugging Face Hub repositories. The _resolve_custom_pipeline_and_cls function in pipeline_loading_utils.py performs string interpolation on the custom_pipeline parameter using f"{custom_pipeline}.py". When custom_pipeline is not supplied by the user, it defaults to None, which Python interpolates as the literal string "None.py". If an attacker publishes a Hub repository containing a file named None.py with a class that subclasses DiffusionPipeline, the file is automatically downloaded and executed during a standard DiffusionPipeline.from_pretrained() call with no additional keyword arguments. The trust_remote_code check in DiffusionPipeline.download() is bypassed because it evaluates custom_pipeline is not None as False (since the kwarg was never supplied), while the downstream code path that actually loads the module resolves the None value into a valid filename. An attacker can achieve silent arbitrary code execution by publishing a malicious model repository with a None.py file and a standard-looking model_index.json that references a legitimate pipeline class name, requiring only that a victim calls from_pretrained on the repository. This vulnerability is fixed in 0.38.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EXPLOITABILITY
2.8
IMPACT
5.9

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
Required (R)
Nécessite une action utilisateur (clic lien, ouverture fichier, etc.)
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-94

> CWE DETAILED DESCRIPTIONS

CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment.

> RED HAT SECURITY ADVISORIES

Red Hat Security Advisory: RHOAI 3.4.4 - Red Hat OpenShift AI
Updated images are now available for Red Hat OpenShift AI.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cuda)
Red Hat AI Inference 3.4.5 (cuda) is now available.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cpu)
Red Hat AI Inference 3.4.5 (cpu) is now available.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cuda)
Red Hat AI Inference 3.4.5 (cuda) is now available.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cpu)
Red Hat AI Inference 3.4.5 (cpu) is now available.
Red Hat Security Advisory: Red Hat Enterprise Linux AI 3.4.5 security update
Updated Red Hat Enterprise Linux AI 3.4.5 container images are now available.
Red Hat Security Advisory: Red Hat Enterprise Linux AI 3.4.5 security update
Updated Red Hat Enterprise Linux AI 3.4.5 container disk images are now available.

> GITHUB SECURITY ADVISORY

GHSA-j7w6-vpvq-j3gm HIGH

Diffusers has a `trust_remote_code` bypass via `custom_pipeline` and local custom components

AFFECTED PACKAGES:
PIP / diffusers
< 0.38.0
Fixed in: 0.38.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Diffusers: None.py Trust Remote Code Bypass

AFFECTED PACKAGES:
Unknown / Unknown
26 versions affected
ALIASES:
GHSA-j7w6-vpvq-j3gm, PYSEC-2026-41

> HISTORIQUE DES MODIFICATIONS

Première apparition
14/05/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/11/2026 06:59
CWE
Champ modifié: Description CWE
Ancienne valeur:
CWE-94: Improper Control of Generation of Code ('Code Injection') - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not n...
Nouvelle valeur:
CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorr...
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-94: Improper Control of Generation of Code ('Code Injection') - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not n...
Total des modifications: 2 Dernière mise à jour: 6 days ago

> REFERENCES

https://github.com/huggingface/diffusers/security/advisories/GHSA-j7w6-vpvq-j3gm
« BACK_TO_HOME