> CVE-2026-44513 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-05-14 17:16
MODIFIED
2026-05-14 17:16
CVSS_SCORE V3
8.8
EPSS (Prob. Exploit)
1.07%
Top 35.1%
DATA SOURCES:
NVD đź”— 2026-05-14 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

Diffusers is the a library for pretrained diffusion models. Prior to 0.38.0, a trust_remote_code bypass in DiffusionPipeline.from_pretrained allows arbitrary remote code execution despite the user passing trust_remote_code=False (or omitting it, which is the default). The vulnerability has three variants, all sharing the same root cause — the trust_remote_code gate was implemented inside DiffusionPipeline.download() rather than at the actual dynamic-module load site, so any code path that bypassed or short-circuited download() also bypassed the security check. DiffusionPipeline.from_pretrained('repoA', custom_pipeline='attacker/repoB', trust_remote_code=False) — the gate evaluated against repoA's file list rather than repoB's, so repoB's pipeline.py was loaded and executed. DiffusionPipeline.from_pretrained('/local/snapshot', custom_pipeline='attacker/repoB', trust_remote_code=False) — the local-path branch never invoked download(), so the gate was never reached and remote code from repoB executed. DiffusionPipeline.from_pretrained('/local/snapshot', trust_remote_code=False) where the snapshot contains custom component files (e.g. unet/my_unet_model.py) referenced from model_index.json — same root cause; the local path skipped download() and custom component code executed. This vulnerability is fixed in 0.38.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EXPLOITABILITY
2.8
IMPACT
5.9

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
Required (R)
Nécessite une action utilisateur (clic lien, ouverture fichier, etc.)
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-94

> CWE DETAILED DESCRIPTIONS

CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment.

> RED HAT SECURITY ADVISORIES

Red Hat Security Advisory: RHOAI 3.4.4 - Red Hat OpenShift AI
Updated images are now available for Red Hat OpenShift AI.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cuda)
Red Hat AI Inference 3.4.5 (cuda) is now available.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cpu)
Red Hat AI Inference 3.4.5 (cpu) is now available.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cuda)
Red Hat AI Inference 3.4.5 (cuda) is now available.
Red Hat Security Advisory: Red Hat AI Inference 3.4.5 (cpu)
Red Hat AI Inference 3.4.5 (cpu) is now available.
Red Hat Security Advisory: Red Hat Enterprise Linux AI 3.4.5 security update
Updated Red Hat Enterprise Linux AI 3.4.5 container images are now available.
Red Hat Security Advisory: Red Hat Enterprise Linux AI 3.4.5 security update
Updated Red Hat Enterprise Linux AI 3.4.5 container disk images are now available.

> GITHUB SECURITY ADVISORY

GHSA-98h9-4798-4q5v HIGH

Diffusers has a `trust_remote_code` bypass via `custom_pipeline` and local custom components

AFFECTED PACKAGES:
PIP / diffusers
< 0.38.0
Fixed in: 0.38.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Diffusers: `trust_remote_code` bypass via `custom_pipeline` and local custom components

AFFECTED PACKAGES:
Unknown / Unknown
26 versions affected
ALIASES:
GHSA-98h9-4798-4q5v, PYSEC-2026-40

> HISTORIQUE DES MODIFICATIONS

Première apparition
14/05/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/11/2026 06:59
CWE
Champ modifié: Description CWE
Ancienne valeur:
CWE-94: Improper Control of Generation of Code ('Code Injection') - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not n...
Nouvelle valeur:
CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorr...
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-94: Improper Control of Generation of Code ('Code Injection') - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not n...
Total des modifications: 2 Dernière mise à jour: 6 days ago

> REFERENCES

https://github.com/huggingface/diffusers/security/advisories/GHSA-98h9-4798-4q5v
« BACK_TO_HOME