> CVE-2026-44477 [CRITICAL]

« BACK_TO_HOME
PUBLISHED
2026-05-28 17:16
MODIFIED
2026-05-28 17:16
CVSS_SCORE V3
9.4
EPSS (Prob. Exploit)
0.48%
Top 58.6%
DATA SOURCES:
NVD đź”— 2026-05-28 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

CloudNativePG is a platform designed to manage PostgreSQL databases within Kubernetes environments. Prior to 1.29.1 and 1.28.3, the CloudNativePG metrics exporter opens its PostgreSQL connection as the postgres superuser via the pod-local Unix socket, then demotes the session with SET ROLE pg_monitor. SET ROLE changes only current_user; session_user remains postgres. Any SQL expression evaluated inside the scrape session can invoke RESET ROLE to recover real superuser privileges, then use COPY ... TO PROGRAM to spawn an OS-level subprocess as the postgres user inside the primary pod. The READ ONLY transaction flag does not block this; it gates writes to database state, not external processes. This vulnerability is fixed in 1.29.1 and 1.28.3.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-250 CWE-271 CWE-426

> CWE DETAILED DESCRIPTIONS

CWE-250: Execution with Unnecessary Privileges - The product performs an operation at a privilege level that is higher than the minimum level required, which creates new weaknesses or amplifies the consequences of other weaknesses. | CWE-271: Privilege Dropping / Lowering Errors - The product does not drop privileges before passing control of a resource to an actor that does not have those privileges. | CWE-426: Untrusted Search Path - The product searches for critical resources using an externally-supplied search path that can point to resources that are not under the product's direct control.

> GITHUB SECURITY ADVISORY

GHSA-423p-g724-fr39 CRITICAL

CloudNativePG's metrics exporter allows privilege escalation to PostgreSQL superuser and OS RCE

AFFECTED PACKAGES:
GO / github.com/cloudnative-pg/cloudnative-pg
>= 1.29.0, < 1.29.1
Fixed in: 1.29.1
GO / github.com/cloudnative-pg/cloudnative-pg
< 1.28.3
Fixed in: 1.28.3

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

CloudNativePG: Metrics exporter allows privilege escalation to PostgreSQL superuser and OS RCE

AFFECTED PACKAGES:
Unknown / Unknown
53 versions affected
ALIASES:
GHSA-423p-g724-fr39, GO-2026-5106

> HISTORIQUE DES MODIFICATIONS

Première apparition
28/05/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-250: Execution with Unnecessary Privileges - The product performs an operation at a privilege level that is higher than the minimum level required, which creates new weaknesses or amplifies the co...
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://github.com/cloudnative-pg/cloudnative-pg/pull/10576
https://github.com/cloudnative-pg/cloudnative-pg/security/advisories/GHSA-423p-g...
« BACK_TO_HOME