> CVE-2026-44312 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-05-14 17:16
MODIFIED
2026-05-14 17:16
CVSS_SCORE V3
5.8
EPSS (Prob. Exploit)
0.15%
Top 96.2%
DATA SOURCES:
NVD đź”— 2026-05-14 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EXPLOITABILITY
3.9
IMPACT
1.4

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Changed (C)
Impact s'étend au-delà du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
Low (L)
Modification limitée des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
Low
Modification limitée des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-295 CWE-829

> CWE DETAILED DESCRIPTIONS

CWE-295: Improper Certificate Validation - The product does not validate, or incorrectly validates, a certificate. | CWE-829: Inclusion of Functionality from Untrusted Control Sphere - The product imports, requires, or includes executable functionality (such as a library) from a source that is outside of the intended control sphere.

> GITHUB SECURITY ADVISORY

GHSA-ff6c-w6qf-7xqc MODERATE

CSS Parser: Improper Certificate Validation allows MITM injection of remote CSS content

AFFECTED PACKAGES:
RUBYGEMS / css_parser
< 1.22.0
Fixed in: 1.22.0
RUBYGEMS / css_parser
>= 2.0.0, < 2.1.0
Fixed in: 2.1.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

css_parser allows to MITM included https css urls

AFFECTED PACKAGES:
Unknown / Unknown
58 versions affected
ALIASES:
GHSA-ff6c-w6qf-7xqc

> HISTORIQUE DES MODIFICATIONS

Première apparition
14/05/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-295: Improper Certificate Validation - The product does not validate, or incorrectly validates, a certificate. | CWE-829: Inclusion of Functionality from Untrusted Control Sphere - The product imp...
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://github.com/premailer/css_parser/commit/35e689c904225add78e0c488cf04bad05...
https://github.com/premailer/css_parser/commit/e0c95d5abe91b237becb90ff316531a65...
https://github.com/premailer/css_parser/issues/185
https://github.com/premailer/css_parser/security/advisories/GHSA-ff6c-w6qf-7xqc
« BACK_TO_HOME