> CVE-2026-44221 [CRITICAL]

« BACK_TO_HOME
PUBLISHED
2026-05-12 20:16
MODIFIED
2026-05-12 20:16
CVSS_SCORE V3
9.0
EPSS (Prob. Exploit)
0.34%
Top 72.8%
DATA SOURCES:
NVD đź”— 2026-05-12 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

ArcadeDB is a Multi-Model DBMS. Prior to 2.6.4, authenticated users and API tokens scoped to a specific database could read, write, and mutate schema on any other database on the same server. Two distinct defects contributed: (1) ServerSecurityUser.getDatabaseUser() returned a DB user with an uninitialized fileAccessMap, which requestAccessOnFile treated as allow-all; (2) ArcadeDBServer.createDatabase() omitted factory.setSecurity(...) so any database created via POST /api/v1/server {"command":"create database X"} had its entire record-level authorization system silently disabled. In combination, record-level and database-level authorization could be bypassed by any authenticated principal. This vulnerability is fixed in 2.6.4.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
EXPLOITABILITY
2.3
IMPACT
6.0

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
Required (R)
Nécessite une action utilisateur (clic lien, ouverture fichier, etc.)
S (Périmètre)
Scope
Changed (C)
Impact s'étend au-delà du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-863

> CWE DETAILED DESCRIPTIONS

CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.

> GITHUB SECURITY ADVISORY

GHSA-fxc7-fm93-6q77 CRITICAL

ArcadeDB vulnerable to cross-database authorization bypass and unsecured newly-created databases

AFFECTED PACKAGES:
MAVEN / com.arcadedb:arcadedb-server
>= 21.10.1, < 26.4.2
Fixed in: 26.4.2

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

ArcadeDB: Cross-database authorization bypass and unsecured newly-created databases

AFFECTED PACKAGES:
Unknown / Unknown
50 versions affected
ALIASES:
GHSA-fxc7-fm93-6q77

> HISTORIQUE DES MODIFICATIONS

Première apparition
12/05/2026 20:16
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://github.com/ArcadeData/arcadedb/commit/04110c06315da55604ac107f71fe7182f3...
https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-fxc7-fm93-6q77
« BACK_TO_HOME