> CVE-2026-44166 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-05-12 18:17
MODIFIED
2026-05-12 18:17
CVSS_SCORE V3
6.1
EPSS (Prob. Exploit)
0.25%
Top 83.9%
DATA SOURCES:
NVD đź”— 2026-05-12 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-10-29 OSV đź”— 2026-11-02

> DESCRIPTION

Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
Unknown (P)
Interaction inconnue
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-287

> CWE DETAILED DESCRIPTIONS

CWE-287: Improper Authentication - When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

> GITHUB SECURITY ADVISORY

GHSA-pq7p-mc74-g65w MODERATE

PocketBase vulnerable to account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade

AFFECTED PACKAGES:
GO / github.com/pocketbase/pocketbase
>= 0.30.0, < 0.37.4
Fixed in: 0.37.4
GO / github.com/pocketbase/pocketbase
< 0.22.42
Fixed in: 0.22.42

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade

AFFECTED PACKAGES:
Unknown / Unknown
167 versions affected
ALIASES:
GHSA-pq7p-mc74-g65w, GO-2026-5548

> HISTORIQUE DES MODIFICATIONS

Première apparition
12/05/2026 18:17
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-287: Improper Authentication - When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://github.com/pocketbase/pocketbase/security/advisories/GHSA-pq7p-mc74-g65w
« BACK_TO_HOME