> CVE-2026-44162 [LOW]

« BACK_TO_HOME
PUBLISHED
2026-09-14 18:17
MODIFIED
2026-09-14 18:17
CVSS_SCORE V3
2.7
EPSS (Prob. Exploit)
0.48%
Top 59.8%
DATA SOURCES:
NVD đź”— 2026-09-14 CWE MITRE đź”— 2026-10-01 FIRST EPSS đź”— 2026-10-18 GITHUB đź”— 2026-09-24 OSV đź”— 2026-10-26

> DESCRIPTION

fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
EXPLOITABILITY
1.2
IMPACT
1.4

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
High (H)
Authentifié avec privilèges administratifs
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-409

> CWE DETAILED DESCRIPTIONS

CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) - The product does not handle or incorrectly handles a compressed input with a very high compression ratio that produces a large output.

> GITHUB SECURITY ADVISORY

GHSA-xv9w-7v6q-hpjh LOW

fluent-plugin-s3 Vulnerable to Denial of Service (DoS) via Decompression Bomb in `in_s3`

AFFECTED PACKAGES:
RUBYGEMS / fluent-plugin-s3
>= 0.7.0, <= 1.8.4
Fixed in: 1.8.5

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`

AFFECTED PACKAGES:
Unknown / Unknown
46 versions affected
ALIASES:
GHSA-xv9w-7v6q-hpjh

> HISTORIQUE DES MODIFICATIONS

Première apparition
14/09/2026 18:17
Source: NVD
📊 ENRICHISSEMENT 01/10/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) - The product does not handle or incorrectly handles a compressed input with a very high compression ratio that produces a lar...
Total des modifications: 1 Dernière mise à jour: 3 weeks ago

> REFERENCES

https://github.com/fluent/fluent-plugin-s3/commit/e085aee001d15bcc4bd073507e7407...
https://github.com/fluent/fluent-plugin-s3/releases/tag/v1.8.5
https://github.com/fluent/fluent-plugin-s3/security/advisories/GHSA-xv9w-7v6q-hp...
« BACK_TO_HOME