> CVE-2026-43914 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-05-11 23:20
MODIFIED
2026-05-11 23:20
CVSS_SCORE V3
7.3
EPSS (Prob. Exploit)
0.29%
Top 78.6%
DATA SOURCES:
NVD đź”— 2026-05-12 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 OSV đź”— 2026-11-02

> DESCRIPTION

Vaultwarden is a Bitwarden-compatible server written in Rust. Prior to 1.35.4, there is a security vulnerability in Vaultwarden that allows bypassing the login brute-force protection if email 2fa is enabled. If email 2fa is enabled, the unprotected 2fa-function send_email_login (email.rs, api endpoint /api/two-factor/send-email-login) also acts as an oracle determining whether a username-password combination is correct. An attacker can abuse that endpoint to brute-force passwords without rate-limiting. This works even for users who don't have email 2fa configured. This vulnerability is fixed in 1.35.4.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EXPLOITABILITY
3.9
IMPACT
3.4

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
Low (L)
Modification limitée des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
Low
Modification limitée des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-307

> CWE DETAILED DESCRIPTIONS

CWE-307: Improper Restriction of Excessive Authentication Attempts - The product does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame.

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Vaultwarden: Brute-force protection bypass vulnerability

AFFECTED PACKAGES:
Unknown / Unknown
77 versions affected
ALIASES:
GHSA-c5rv-q295-7w4g

> HISTORIQUE DES MODIFICATIONS

Première apparition
11/05/2026 23:20
Source: NVD
📊 ENRICHISSEMENT 01/06/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-307: Improper Restriction of Excessive Authentication Attempts - The product does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame.
Total des modifications: 1 Dernière mise à jour: 5 months ago

> REFERENCES

https://github.com/dani-garcia/vaultwarden/pull/6867
https://github.com/dani-garcia/vaultwarden/releases/tag/1.35.4
https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w...
« BACK_TO_HOME