> CVE-2026-41871

« BACK_TO_HOME
PUBLISHED
2026-09-09 11:17
MODIFIED
2026-09-09 11:17
EPSS (Prob. Exploit)
0.75%
Top 45.7%
DATA SOURCES:
NVD 🔗 2026-09-09 CWE MITRE 🔗 2026-10-01 FIRST EPSS 🔗 2026-10-25

> DESCRIPTION

Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> WEAKNESSES

CWE-470 CWE-862

> CWE DETAILED DESCRIPTIONS

CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') - The product uses external input with reflection to select which classes or code to use, but it does not sufficiently prevent the input from selecting improper classes or code. | CWE-862: Missing Authorization - The product does not perform an authorization check when an actor attempts to access a resource or perform an action.

> HISTORIQUE DES MODIFICATIONS

Première apparition
09/09/2026 11:17
Source: NVD
📊 ENRICHISSEMENT 01/10/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') - The product uses external input with reflection to select which classes or code to use, but it does not su...
Total des modifications: 1 Dernière mise à jour: 3 weeks ago

> REFERENCES

https://lists.apache.org/thread/rbr63fx8vlrhzrfknq2l0mg0d0blsl54
« BACK_TO_HOME