> CVE-2026-41386 [CRITICAL]

« BACK_TO_HOME
PUBLISHED
2026-04-28 19:37
MODIFIED
2026-04-28 19:37
CVSS_SCORE V3
9.1
EPSS (Prob. Exploit)
0.33%
Top 74.0%
DATA SOURCES:
NVD đź”— 2026-04-28 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-08 GITHUB đź”— 2026-10-29 OSV đź”— 2026-11-02

> DESCRIPTION

OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can exploit this during first-use device pairing to escalate privileges beyond their intended role and scope.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-648

> CWE DETAILED DESCRIPTIONS

CWE-648: Incorrect Use of Privileged APIs - The product does not conform to the API requirements for a function call that requires extra privileges. This could allow attackers to gain privileges by causing the function to be called incorrectly.

> GITHUB SECURITY ADVISORY

GHSA-gg9v-mgcp-v6m7 HIGH

OpenClaw: Unbound bootstrap setup codes allow privilege escalation during pairing

AFFECTED PACKAGES:
NPM / openclaw
<= 2026.3.13-1
Fixed in: 2026.3.22

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes

AFFECTED PACKAGES:
Unknown / Unknown
79 versions affected
ALIASES:
GHSA-gg9v-mgcp-v6m7

> HISTORIQUE DES MODIFICATIONS

Première apparition
28/04/2026 19:37
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-648: Incorrect Use of Privileged APIs - The product does not conform to the API requirements for a function call that requires extra privileges. This could allow attackers to gain privileges by ca...
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/openclaw/openclaw/commit/a600c72ed7d0045a27f58bf031d2b36ecb01...
https://github.com/openclaw/openclaw/security/advisories/GHSA-gg9v-mgcp-v6m7
https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-unbound-b...
« BACK_TO_HOME