> CVE-2026-41271 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-04-23 20:16
MODIFIED
2026-04-23 20:16
CVSS_SCORE V3
7.1
EPSS (Prob. Exploit)
0.23%
Top 85.8%
DATA SOURCES:
NVD 🔗 2026-04-23 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-08 GITHUB 🔗 2026-10-29 OSV 🔗 2026-11-02

> DESCRIPTION

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
EXPLOITABILITY
1.6
IMPACT
5.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-918

> CWE DETAILED DESCRIPTIONS

CWE-918: Server-Side Request Forgery - The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.

> GITHUB SECURITY ADVISORY

GHSA-6r77-hqx7-7vw8 HIGH

Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains

AFFECTED PACKAGES:
NPM / flowise-components
<= 3.0.13
Fixed in: 3.1.0
NPM / flowise
<= 3.0.13
Fixed in: 3.1.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains

AFFECTED PACKAGES:
Unknown / Unknown
273 versions affected
ALIASES:
GHSA-6r77-hqx7-7vw8

> HISTORIQUE DES MODIFICATIONS

Première apparition
23/04/2026 20:16
Source: NVD
📊 ENRICHISSEMENT 01/11/2026 06:59
CWE
Champ modifié: Description CWE
Ancienne valeur:
CWE-918: Server-Side Request Forgery (SSRF) - The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure th...
Nouvelle valeur:
CWE-918: Server-Side Request Forgery - The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the ...
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-918: Server-Side Request Forgery (SSRF) - The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure th...
Total des modifications: 2 Dernière mise à jour: 1 week ago

> REFERENCES

https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6r77-hqx7-7vw8
https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6r77-hqx7-7vw8
« BACK_TO_HOME