> CVE-2026-41268 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-04-23 20:16
MODIFIED
2026-04-23 20:16
CVSS_SCORE V3
7.7
EPSS (Prob. Exploit)
17.44%
Top 2.9%
⚡ EPSS ÉLEVÉ (17.4%)
DATA SOURCES:
NVD 🔗 2026-04-23 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-08 GITHUB 🔗 2026-10-29 OSV 🔗 2026-11-02

> DESCRIPTION

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
EXPLOITABILITY
2.2
IMPACT
5.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-20

> CWE DETAILED DESCRIPTIONS

CWE-20: Improper Input Validation - The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

> GITHUB SECURITY ADVISORY

GHSA-cvrr-qhgw-2mm6 HIGH

Flowise: Parameter Override Bypass Remote Command Execution

AFFECTED PACKAGES:
NPM / flowise-components
<= 3.0.13
Fixed in: 3.1.0
NPM / flowise
<= 3.0.13
Fixed in: 3.1.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Flowise: Flowise Parameter Override Bypass Remote Command Execution

AFFECTED PACKAGES:
Unknown / Unknown
273 versions affected
ALIASES:
GHSA-cvrr-qhgw-2mm6

> HISTORIQUE DES MODIFICATIONS

Première apparition
23/04/2026 20:16
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process...
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6
« BACK_TO_HOME