> CVE-2026-40870 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-04-21 20:17
MODIFIED
2026-04-21 20:17
CVSS_SCORE V3
7.5
EPSS (Prob. Exploit)
0.39%
Top 67.6%
DATA SOURCES:
NVD đź”— 2026-04-21 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-10-25 GITHUB đź”— 2026-11-05

> DESCRIPTION

Decidim is a participatory democracy framework. Starting in version 0.0.1 and prior to versions 0.30.5 and 0.31.1, the root level `commentable` field in the API allows access to all commentable resources within the platform, without any permission checks. All Decidim instances are impacted that have not secured the `/api` endpoint. The `/api` endpoint is publicly available with the default configuration. Versions 0.30.5 and 0.31.1 fix the issue. As a workaround, limit the scope to only authenticated users by limiting access to the `/api` endpoint. This would require custom code or installing the 3rd party module `Decidim::Apiauth`. With custom code, the `/api` endpoint can be limited to only authenticated users. The same configuration can be also used without the `allow` statements to disable all traffic to the the `/api` endpoint. When considering a workaround and the seriousness of the vulnerability, please consider the nature of the platform. If the platform is primarily serving public data, this vulnerability is not serious by its nature. If the platform is protecting some resources, e.g. inside private participation spaces, the vulnerability may expose some data to the attacker that is not meant public. For those who have enabled the organization setting "Force users to authenticate before access organization", the scope of this vulnerability is limited to the users who are allowed to log in to the Decidim platform. This setting was introduced in version 0.19.0 and it was applied to the `/api` endpoint in version 0.22.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EXPLOITABILITY
3.9
IMPACT
3.6

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-862

> CWE DETAILED DESCRIPTIONS

CWE-862: Missing Authorization - The product does not perform an authorization check when an actor attempts to access a resource or perform an action.

> GITHUB SECURITY ADVISORY

GHSA-ghmh-q25g-gxxx HIGH

Decidim's comments API allows access to all commentable resources

AFFECTED PACKAGES:
RUBYGEMS / decidim-api
>= 0.0.1, < 0.30.5
Fixed in: 0.30.5
RUBYGEMS / decidim-comments
>= 0.0.1, < 0.30.5
Fixed in: 0.30.5
RUBYGEMS / decidim-api
> 0.31.0.rc1, < 0.31.1
Fixed in: 0.31.1
RUBYGEMS / decidim-comments
> 0.31.0.rc1, < 0.31.1
Fixed in: 0.31.1

> HISTORIQUE DES MODIFICATIONS

Première apparition
21/04/2026 20:17
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-862: Missing Authorization - The product does not perform an authorization check when an actor attempts to access a resource or perform an action.
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/decidim/decidim/security/advisories/GHSA-ghmh-q25g-gxxx
« BACK_TO_HOME