PUBLISHED
2026-04-24 11:16
MODIFIED
2026-04-24 11:16
EPSS (Prob. Exploit)
4.11%
Top 9.3%
> DESCRIPTION
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.
An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath.
A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().
This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5.
Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.
> AFFECTED_PRODUCTS
ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.
> CWE DETAILED DESCRIPTIONS
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process the data safely and
correctly. | CWE-94: Improper Control of Generation of Code - The product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment.
> GITHUB SECURITY ADVISORY
GHSA-w3w2-mpp5-92gm
HIGH
Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection
AFFECTED PACKAGES:
MAVEN / org.apache.activemq:activemq-broker
>= 6.0.0, < 6.2.5
Fixed in: 6.2.5
MAVEN / org.apache.activemq:activemq-all
>= 6.0.0, < 6.2.5
Fixed in: 6.2.5
MAVEN / org.apache.activemq:apache-activemq
>= 6.0.0, < 6.2.5
Fixed in: 6.2.5
MAVEN / org.apache.activemq:activemq-broker
< 5.19.6
Fixed in: 5.19.6
MAVEN / org.apache.activemq:activemq-all
< 5.19.6
Fixed in: 5.19.6
MAVEN / org.apache.activemq:apache-activemq
< 5.19.6
Fixed in: 5.19.6
> NUCLEI TEMPLATES
Des templates Nuclei sont disponibles pour scanner cette vulnérabilité.
Usage: nuclei -t http/cves/2026/CVE-2026-40466.yaml -u target.com
> HISTORIQUE DES MODIFICATIONS
Première apparition
24/04/2026 11:16
Source: NVD
📊
ENRICHISSEMENT
01/11/2026 06:59
CWE
Champ modifié: Description CWE
Ancienne valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process...
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process...
📊
ENRICHISSEMENT
01/05/2026 06:01
CWE
Champ modifié: Description CWE
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does
not validate or incorrectly validates that the input has the
properties that are required to process...
Total des modifications: 2
Dernière mise à jour: 1 week ago