> CVE-2026-38991

« BACK_TO_HOME
PUBLISHED
2026-04-29 16:16
MODIFIED
2026-04-29 16:16
EPSS (Prob. Exploit)
0.54%
Top 55.4%
DATA SOURCES:
NVD 🔗 2026-04-29 FIRST EPSS 🔗 2026-10-25 GITHUB 🔗 2026-11-05

> DESCRIPTION

Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> GITHUB SECURITY ADVISORY

GHSA-j2rx-4jg9-79mw HIGH

Cockpit Vulnerable to Unrestricted Upload of File with Dangerous Type

AFFECTED PACKAGES:
COMPOSER / cockpit-hq/cockpit
< 2.14.0
Fixed in: 2.14.0

> HISTORIQUE DES MODIFICATIONS

Première apparition
29/04/2026 16:16
Source: NVD
Total des modifications: 0 Dernière mise à jour: 6 months ago

> REFERENCES

https://felsec.com/posts/cockpit-cms-2.13.5-multi-vulns/
https://github.com/Cockpit-HQ/Cockpit/releases/tag/2.14.0
« BACK_TO_HOME