> CVE-2026-35645 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-04-09 22:16
MODIFIED
2026-04-09 22:16
CVSS_SCORE V3
6.1
EPSS (Prob. Exploit)
0.29%
Top 78.9%
DATA SOURCES:
NVD đź”— 2026-04-09 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-08 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that uses a synthetic operator.admin runtime scope. Attackers can exploit this by triggering session deletion without a request-scoped client to execute privileged operations with unintended administrative scope.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-648

> CWE DETAILED DESCRIPTIONS

CWE-648: Incorrect Use of Privileged APIs - The product does not conform to the API requirements for a function call that requires extra privileges. This could allow attackers to gain privileges by causing the function to be called incorrectly.

> GITHUB SECURITY ADVISORY

GHSA-h4jx-hjr3-fhgc MODERATE

OpenClaw: Gateway Plugin Subagent Fallback `deleteSession` Uses Synthetic `operator.admin`

AFFECTED PACKAGES:
NPM / openclaw
<= 2026.3.24
Fixed in: 2026.3.28

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

OpenClaw < 2026.3.25 - Privilege Escalation via Synthetic operator.admin in deleteSession

AFFECTED PACKAGES:
Unknown / Unknown
87 versions affected
ALIASES:
GHSA-h4jx-hjr3-fhgc

> HISTORIQUE DES MODIFICATIONS

Première apparition
09/04/2026 22:16
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-648: Incorrect Use of Privileged APIs - The product does not conform to the API requirements for a function call that requires extra privileges. This could allow attackers to gain privileges by ca...
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/openclaw/openclaw/commit/b5d785f1a59a56c3471f2cef328f7c9a6c15...
https://github.com/openclaw/openclaw/security/advisories/GHSA-h4jx-hjr3-fhgc
https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-synthetic...
« BACK_TO_HOME