> CVE-2026-34236 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-04-01 18:16
MODIFIED
2026-04-01 18:16
CVSS_SCORE V3
8.2
EPSS (Prob. Exploit)
0.22%
Top 86.8%
DATA SOURCES:
NVD 🔗 2026-04-01 CWE MITRE 🔗 2026-11-01 FIRST EPSS 🔗 2026-11-08 GITHUB 🔗 2026-11-05 OSV 🔗 2026-11-01

> DESCRIPTION

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
EXPLOITABILITY
1.8
IMPACT
5.8

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Changed (C)
Impact s'étend au-delà du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-331

> CWE DETAILED DESCRIPTIONS

CWE-331: Insufficient Entropy - The product uses an algorithm or scheme that produces insufficient entropy, leaving patterns or clusters of values that are more likely to occur than others.

> GITHUB SECURITY ADVISORY

GHSA-w3wc-44p4-m4j7 HIGH

Auth0 PHP SDK has Insufficient Entropy in Cookie Encryption

AFFECTED PACKAGES:
COMPOSER / auth0/auth0-php
>= 8.0.0, <= 8.18.0
Fixed in: 8.19.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Auth0 PHP SDK Insufficient Entropy in Cookie Encryption

AFFECTED PACKAGES:
Unknown / Unknown
37 versions affected
ALIASES:
GHSA-w3wc-44p4-m4j7

> HISTORIQUE DES MODIFICATIONS

Première apparition
01/04/2026 18:16
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-331: Insufficient Entropy - The product uses an algorithm or scheme that produces insufficient entropy, leaving patterns or clusters of values that are more likely to occur than others.
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/auth0/auth0-PHP/releases/tag/8.19.0
https://github.com/auth0/auth0-PHP/security/advisories/GHSA-w3wc-44p4-m4j7
« BACK_TO_HOME