> CVE-2026-33888 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-04-15 20:16
MODIFIED
2026-04-15 20:16
CVSS_SCORE V3
5.3
EPSS (Prob. Exploit)
0.51%
Top 56.1%
DATA SOURCES:
NVD đź”— 2026-04-15 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-08 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-02

> DESCRIPTION

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain an authorization bypass vulnerability in the getRestQuery method of the @apostrophecms/piece-type module, where the method checks whether a MongoDB projection has already been set before applying the admin-configured publicApiProjection. An unauthenticated attacker can supply a project query parameter in the REST API request, which is processed by applyBuildersSafely before the permission check, pre-populating the projection state and causing the publicApiProjection to be skipped entirely. This allows disclosure of any field on publicly queryable documents that the administrator explicitly restricted from the public API, such as internal notes, draft content, or metadata. Exploitation is trivial, requiring only appending query parameters to a public URL with no authentication. This issue has been fixed in version 4.29.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EXPLOITABILITY
3.9
IMPACT
1.4

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-200 CWE-863

> CWE DETAILED DESCRIPTIONS

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor - The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information. | CWE-863: Incorrect Authorization - The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.

> GITHUB SECURITY ADVISORY

GHSA-xhq9-58fw-859p MODERATE

ApostropheCMS: publicApiProjection Bypass via project Query Builder in Piece-Type REST API

AFFECTED PACKAGES:
NPM / apostrophe
< 4.29.0
Fixed in: 4.29.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API

AFFECTED PACKAGES:
Unknown / Unknown
670 versions affected
ALIASES:
GHSA-xhq9-58fw-859p

> HISTORIQUE DES MODIFICATIONS

Première apparition
15/04/2026 20:16
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor - The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information. | CWE-...
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/apostrophecms/apostrophe/commit/00d472804bb622df36a761b6f2cf2...
https://github.com/apostrophecms/apostrophe/commit/6c2b548dec2e3f7a82e8e16736603...
https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-xhq9-58fw-8...
« BACK_TO_HOME