> CVE-2026-33762 [LOW]

« BACK_TO_HOME
PUBLISHED
2026-03-31 15:16
MODIFIED
2026-03-31 15:16
CVSS_SCORE V3
2.8
EPSS (Prob. Exploit)
0.15%
Top 95.9%
DATA SOURCES:
NVD đź”— 2026-03-31 RED HAT đź”— 2026-04-05 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-10-25 GITHUB đź”— 2026-11-05 OSV đź”— 2026-04-07

> DESCRIPTION

go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
EXPLOITABILITY
1.3
IMPACT
1.4

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Local (L)
Exploit nécessite un accès local au système
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
Required (R)
Nécessite une action utilisateur (clic lien, ouverture fichier, etc.)
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
Low (L)
Interruption partielle du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
Low
Interruption partielle du service possible

> WEAKNESSES

CWE-129

> CWE DETAILED DESCRIPTIONS

CWE-129: Improper Validation of Array Index - The product uses untrusted input when calculating or using an array index, but the product does not validate or incorrectly validates the index to ensure the index references a valid position within the array.

> RED HAT SEVERITY ASSESSMENT

THREAT SEVERITY
Low

> GITHUB SECURITY ADVISORY

GHSA-gm2x-2g9h-ccm8 LOW

go-git missing validation decoding Index v4 files leads to panic

AFFECTED PACKAGES:
GO / github.com/go-git/go-git/v5
<= 5.17.0
Fixed in: 5.17.1

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

go-git: Missing validation decoding Index v4 files leads to panic

AFFECTED PACKAGES:
Unknown / Unknown
86 versions affected
ALIASES:
GHSA-gm2x-2g9h-ccm8

> HISTORIQUE DES MODIFICATIONS

Première apparition
31/03/2026 15:16
Source: NVD
📊 ENRICHISSEMENT 05/04/2026 05:02
REDHAT
Champ modifié: Sévérité Red Hat
Ancienne valeur:
N/A
Nouvelle valeur:
{ "threat_severity": "Low", "severity_scale": null }
📊 ENRICHISSEMENT 05/04/2026 05:02
REDHAT
Champ modifié: Red Hat
Ancienne valeur:
Non
Nouvelle valeur:
Oui
📊 ENRICHISSEMENT 01/04/2026 06:02
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-129: Improper Validation of Array Index - The product uses untrusted input when calculating or using an array index, but the product does not validate or incorrectly validates the index to ensure ...
Total des modifications: 3 Dernière mise à jour: 7 months ago

> REFERENCES

https://github.com/go-git/go-git/releases/tag/v5.17.1
https://github.com/go-git/go-git/security/advisories/GHSA-gm2x-2g9h-ccm8
« BACK_TO_HOME