> CVE-2026-33409 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-03-24 19:16
MODIFIED
2026-03-24 19:16
CVSS_SCORE V3
7.0
EPSS (Prob. Exploit)
0.47%
Top 58.9%
DATA SOURCES:
NVD đź”— 2026-03-24 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-08 GITHUB đź”— 2026-11-05 OSV đź”— 2026-11-01

> DESCRIPTION

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
High (H)
Authentifié avec privilèges administratifs
UI (Interaction Utilisateur)
User Interaction
Required (R)
Nécessite une action utilisateur (clic lien, ouverture fichier, etc.)
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-287

> CWE DETAILED DESCRIPTIONS

CWE-287: Improper Authentication - When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

> GITHUB SECURITY ADVISORY

GHSA-pfj7-wv7c-22pr HIGH

Parse Server has an auth provider validation bypass on login via partial authData

AFFECTED PACKAGES:
NPM / parse-server
< 8.6.52
Fixed in: 8.6.52
NPM / parse-server
>= 9.0.0, < 9.6.0-alpha.41
Fixed in: 9.6.0-alpha.41

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

Parse Server: Auth provider validation bypass on login via partial authData

AFFECTED PACKAGES:
Unknown / Unknown
259 versions affected
ALIASES:
BIT-parse-2026-33409, GHSA-pfj7-wv7c-22pr

> HISTORIQUE DES MODIFICATIONS

Première apparition
24/03/2026 19:16
Source: NVD
📊 ENRICHISSEMENT 01/04/2026 06:02
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-287: Improper Authentication - When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
Total des modifications: 1 Dernière mise à jour: 7 months ago

> REFERENCES

https://github.com/parse-community/parse-server/commit/8d7df5639c4a35768fe8b78b4...
https://github.com/parse-community/parse-server/commit/98f4ba5bcf2c199bfe6225f67...
https://github.com/parse-community/parse-server/pull/10246
https://github.com/parse-community/parse-server/pull/10247
https://github.com/parse-community/parse-server/security/advisories/GHSA-pfj7-wv...
« BACK_TO_HOME