> CVE-2026-33318 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-04-24 03:16
MODIFIED
2026-04-24 03:16
CVSS_SCORE V3
8.8
EPSS (Prob. Exploit)
0.59%
Top 52.4%
DATA SOURCES:
NVD đź”— 2026-04-24 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-10-25 GITHUB đź”— 2026-11-05

> DESCRIPTION

Actual is a local-first personal finance tool. Prior to version 26.4.0, any authenticated user (including `BASIC` role) can escalate to `ADMIN` on servers migrated from password authentication to OpenID Connect. Three weaknesses combine: `POST /account/change-password` has no authorization check, allowing any session to overwrite the password hash; the inactive password `auth` row is never removed on migration; and the login endpoint accepts a client-supplied `loginMethod` that bypasses the server's active auth configuration. Together these allow an attacker to set a known password and authenticate as the anonymous admin account created during the multiuser migration. The three weaknesses form a single, sequential exploit chain — none produces privilege escalation on its own. Missing authorization on POST /change-password allows overwriting a password hash, but only matters if there is an orphaned row to target. Orphaned password row persisting after migration provides the target row, but is harmless without the ability to authenticate using it. Client-controlled loginMethod: "password" allows forcing password-based auth, but is useless without a known hash established by step 1. All three must be chained in sequence to achieve the impact. No single weakness independently results in privilege escalation. The single root cause is the missing authorization check on /change-password; the other two are preconditions that make it exploitable. Version 26.4.0 contains a fix.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EXPLOITABILITY
2.8
IMPACT
5.9

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-284 CWE-862

> CWE DETAILED DESCRIPTIONS

CWE-284: Improper Access Control - The product does not restrict or incorrectly restricts access to a resource from an unauthorized actor. | CWE-862: Missing Authorization - The product does not perform an authorization check when an actor attempts to access a resource or perform an action.

> GITHUB SECURITY ADVISORY

GHSA-prp4-2f49-fcgp HIGH

Actual has Privilege Escalation via 'change-password' Endpoint on OpenID-Migrated Servers

AFFECTED PACKAGES:
NPM / @actual-app/sync-server
< 26.4.0
Fixed in: 26.4.0

> HISTORIQUE DES MODIFICATIONS

Première apparition
24/04/2026 03:16
Source: NVD
📊 ENRICHISSEMENT 01/05/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-284: Improper Access Control - The product does not restrict or incorrectly restricts access to a resource from an unauthorized actor. | CWE-862: Missing Authorization - The product does not perfo...
Total des modifications: 1 Dernière mise à jour: 6 months ago

> REFERENCES

https://actualbudget.org/blog/release-26.4.0
https://github.com/actualbudget/actual/security/advisories/GHSA-prp4-2f49-fcgp
« BACK_TO_HOME