PUBLISHED
2026-03-30 22:16
MODIFIED
2026-03-30 22:16
EPSS (Prob. Exploit)
0.39%
Top 66.7%
> DESCRIPTION
Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice.
This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0.
Users are recommended to upgrade to version 1.12.0, which fixes the issue.
> AFFECTED_PRODUCTS
ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.
> CWE DETAILED DESCRIPTIONS
CWE-295: Improper Certificate Validation - The product does not validate, or incorrectly validates, a certificate.
> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)
Apache Airflow Provider for Databricks: TLS Certificate Verification Disabled in Databricks Provider K8s Token Exchange
AFFECTED PACKAGES:
Unknown / Unknown
560 versions affected
ALIASES:
GHSA-wrpj-755p-x363, PYSEC-2026-2357
> HISTORIQUE DES MODIFICATIONS
Première apparition
30/03/2026 22:16
Source: NVD
📊
ENRICHISSEMENT
01/04/2026 06:02
CWE
Champ modifié: Description CWE
Nouvelle valeur:
CWE-295: Improper Certificate Validation - The product does not validate, or incorrectly validates, a certificate.
Total des modifications: 1
Dernière mise à jour: 7 months ago