> CVE-2026-18504 [MEDIUM]

« BACK_TO_HOME
PUBLISHED
2026-08-18 21:16
MODIFIED
2026-08-18 21:16
CVSS_SCORE V3
5.4
EPSS (Prob. Exploit)
0.31%
Top 77.4%
DATA SOURCES:
NVD 🔗 2026-08-18 CWE MITRE 🔗 2026-09-01 FIRST EPSS 🔗 2026-10-25 GITHUB 🔗 2026-10-29 OSV 🔗 2026-08-25

> DESCRIPTION

fastify is a fast and low overhead web framework for Node.js. Versions of fastify before 5.12.1 are affected by a schema validation bypass when a request body schema targets a root primitive value. When the schema validates a top-level primitive such as an integer, Ajv can coerce a JSON string into the expected type during validation, but Fastify does not replace the root request body with the coerced value, so the route handler receives the original unvalidated string. As a result, a request that should have failed validation can reach application logic with a value that does not satisfy the schema, which can undermine integrity and access-control checks that rely on the validated type. Users should upgrade to fastify 5.12.1, which fixes the mismatch. No known workarounds are available.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EXPLOITABILITY
2.8
IMPACT
2.5

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
Low (L)
Authentifié avec compte utilisateur basique
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
Low (L)
Divulgation limitée d'informations
I (Impact Intégrité)
Integrity Impact
Low (L)
Modification limitée des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
Low
Divulgation limitée d'informations
Intégrité
Low
Modification limitée des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-20

> CWE DETAILED DESCRIPTIONS

CWE-20: Improper Input Validation - The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

> GITHUB SECURITY ADVISORY

GHSA-w2qp-rph6-63g4 MODERATE

fastify vulnerable to schema validation bypass via root primitive coercion mismatch

AFFECTED PACKAGES:
NPM / fastify
< 5.12.1
Fixed in: 5.12.1

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

fastify vulnerable to schema validation bypass via root primitive coercion mismatch

AFFECTED PACKAGES:
Unknown / Unknown
232 versions affected
ALIASES:
GHSA-w2qp-rph6-63g4

> HISTORIQUE DES MODIFICATIONS

Première apparition
18/08/2026 21:16
Source: NVD
📊 ENRICHISSEMENT 01/09/2026 06:02
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-20: Improper Input Validation - The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process...
Total des modifications: 1 Dernière mise à jour: 1 month ago

> REFERENCES

https://cna.openjsf.org/security-advisories.html
https://github.com/fastify/fastify/security/advisories/GHSA-w2qp-rph6-63g4
« BACK_TO_HOME