> CVE-2026-18446 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-07-31 15:16
MODIFIED
2026-07-31 15:16
CVSS_SCORE V3
7.5
EPSS (Prob. Exploit)
0.22%
Top 87.9%
DATA SOURCES:
NVD đź”— 2026-07-31 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-10-25 GITHUB đź”— 2026-10-29 OSV đź”— 2026-08-07

> DESCRIPTION

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EXPLOITABILITY
3.9
IMPACT
3.6

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
Low (L)
Peu de conditions requises pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
None (N)
Aucune divulgation d'informations
I (Impact Intégrité)
Integrity Impact
High (H)
Modification totale des données possible
A (Impact Disponibilité)
Availability Impact
None (N)
Aucune interruption de service

> RÉSUMÉ DES IMPACTS

Confidentialité
None
Aucune divulgation d'informations
Intégrité
High
Modification totale des données possible
Disponibilité
None
Aucune interruption de service

> WEAKNESSES

CWE-436

> CWE DETAILED DESCRIPTIONS

CWE-436: Interpretation Conflict - Product A handles inputs or steps differently than Product B, which causes A to perform incorrect actions based on its perception of B's state.

> RED HAT SECURITY ADVISORIES

Red Hat Security Advisory: OpenShift Container Platform 4.16.70 bug fix and security update
Red Hat OpenShift Container Platform release 4.16.70 is now available with updates to packages and images that fix several bugs and add enhancements. This release includes a security update for Red...
Red Hat Security Advisory: OpenShift Container Platform 4.22.15 security and extras update
Red Hat OpenShift Container Platform release 4.22.15 is now available with updates to packages and images that fix several bugs. This release includes a security update for Red Hat OpenShift Containe...
Red Hat Security Advisory: OpenShift Container Platform 4.21.34 security and extras update
Red Hat OpenShift Container Platform release 4.21.34 is now available with updates to packages and images that fix several bugs. This release includes a security update for Red Hat OpenShift Containe...
Red Hat Security Advisory: OpenShift Container Platform 4.22.16 bug fix and security update
Red Hat OpenShift Container Platform release 4.22.16 is now available with updates to packages and images that fix several bugs and add enhancements. This release includes a security update for Red...
Red Hat Security Advisory: RHOAI 3.4.5 - Red Hat OpenShift AI
Updated images are now available for Red Hat OpenShift AI.
Red Hat Security Advisory: RHOAI 2.25.12 - Red Hat OpenShift AI
Updated images are now available for Red Hat OpenShift AI.
Red Hat Security Advisory: RHOAI 3.4.6 - Red Hat OpenShift AI
Updated images are now available for Red Hat OpenShift AI.

> GITHUB SECURITY ADVISORY

GHSA-7p8r-x3mc-p8w7 HIGH

fast-uri vulnerable to host confusion via backslash authority introducer

AFFECTED PACKAGES:
NPM / fast-uri
>= 4.0.0, < 4.1.2
Fixed in: 4.1.2
NPM / fast-uri
>= 3.0.0, < 3.1.5
Fixed in: 3.1.5
NPM / fast-uri
< 2.4.4
Fixed in: 2.4.4

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

fast-uri vulnerable to host confusion via backslash authority introducer

AFFECTED PACKAGES:
Unknown / Unknown
29 versions affected
ALIASES:
GHSA-7p8r-x3mc-p8w7

> HISTORIQUE DES MODIFICATIONS

Première apparition
31/07/2026 15:16
Source: NVD
📊 ENRICHISSEMENT 01/08/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-436: Interpretation Conflict - Product A handles inputs or steps differently than Product B, which causes A to perform incorrect actions based on its perception of B's state.
Total des modifications: 1 Dernière mise à jour: 3 months ago

> REFERENCES

https://cna.openjsf.org/security-advisories.html
https://github.com/fastify/fast-uri/security/advisories/GHSA-7p8r-x3mc-p8w7
« BACK_TO_HOME