> CVE-2026-13697 [HIGH]

« BACK_TO_HOME
PUBLISHED
2026-07-29 17:16
MODIFIED
2026-07-29 17:16
CVSS_SCORE V3
7.4
EPSS (Prob. Exploit)
0.57%
Top 52.8%
DATA SOURCES:
NVD đź”— 2026-07-29 CWE MITRE đź”— 2026-11-01 FIRST EPSS đź”— 2026-11-01 GITHUB đź”— 2026-10-29 OSV đź”— 2026-11-02

> DESCRIPTION

undici's cache interceptor mishandles malformed Cache-Control private directives. In undici 7.0.0 up to before 7.29.0 and 8.0.0 up to before 8.9.0, a response carrying a degenerate qualified private directive, such as private set to an empty value, can be stored in the default shared cache and later served to a different caller with the same cache key, disclosing private response bodies and headers including Set-Cookie. Separately, a Cache-Control header that combines an unqualified private directive with a qualified one triggers an uncaught TypeError in the cache-control parser, which rejects the request and, depending on the consumer's error handling, can terminate the process. Both issues affect applications using the cache interceptor in shared mode, including the default configuration. The issues are fixed in undici 7.29.0 and 8.9.0.

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> CVSS V3 METRICS

CVSS_VECTOR
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
EXPLOITABILITY
2.2
IMPACT
5.2

> MÉTRIQUES CVSS DÉTAILLÉES

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Métrique Valeur Interprétation
AV (Vecteur d'Attaque)
Attack Vector
Network (N)
Exploit possible à distance via réseau (HTTP, API, etc.)
AC (Complexité d'Attaque)
Attack Complexity
High (H)
Conditions spécifiques doivent être réunies pour exploiter
PR (Privilèges Requis)
Privileges Required
None (N)
Aucune authentification requise
UI (Interaction Utilisateur)
User Interaction
None (N)
Aucune interaction utilisateur nécessaire
S (Périmètre)
Scope
Unchanged (U)
Impact reste dans le périmètre du composant compromis
C (Impact Confidentialité)
Confidentiality Impact
High (H)
Divulgation totale d'informations
I (Impact Intégrité)
Integrity Impact
None (N)
Aucune modification de données possible
A (Impact Disponibilité)
Availability Impact
High (H)
Interruption totale du service possible

> RÉSUMÉ DES IMPACTS

Confidentialité
High
Divulgation totale d'informations
Intégrité
None
Aucune modification de données possible
Disponibilité
High
Interruption totale du service possible

> WEAKNESSES

CWE-200 CWE-248 CWE-525

> CWE DETAILED DESCRIPTIONS

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor - The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information. | CWE-248: Uncaught Exception - An exception is thrown from a function, but it is not caught. | CWE-525: Use of Web Browser Cache Containing Sensitive Information - The web application does not use an appropriate caching policy that specifies the extent to which each web page and associated form fields should be cached.

> RED HAT SECURITY ADVISORIES

Red Hat Security Advisory: Red Hat Developer Hub 1.10.5 Plugin Catalog GA plugins release.
Red Hat Developer Hub 1.10.5 Plugin Catalog GA plugins release.
Red Hat Security Advisory: Red Hat Developer Hub 1.10.5 release.
Red Hat Developer Hub 1.10.5 has been released.
Red Hat Security Advisory: Ansible automation portal Red Hat Enterprise Linux Images
Updated images are now available for Red Hat Ansible Automation Platform 2.2, which include new features, bug fixes, and enhancements for the Red Hat Ansible Automation Portal bootable container image...
Red Hat Security Advisory: RHOAI 3.5.2 - Red Hat OpenShift AI
Updated images are now available for Red Hat OpenShift AI.
Red Hat Security Advisory: Red Hat OpenShift Dev Spaces 3.31.0 Release.
Red Hat OpenShift Dev Spaces 3.31.0 has been released.

> GITHUB SECURITY ADVISORY

GHSA-4cwx-7wf7-3272 HIGH

undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives

AFFECTED PACKAGES:
NPM / undici
>= 8.0.0, < 8.9.0
Fixed in: 8.9.0
NPM / undici
>= 7.0.0, < 7.29.0
Fixed in: 7.29.0

> OSV (GOOGLE OPEN SOURCE VULNERABILITIES)

undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives

AFFECTED PACKAGES:
Unknown / Unknown
60 versions affected
ALIASES:
GHSA-4cwx-7wf7-3272

> HISTORIQUE DES MODIFICATIONS

Première apparition
29/07/2026 17:16
Source: NVD
📊 ENRICHISSEMENT 01/08/2026 06:01
CWE
Champ modifié: Description CWE
Ancienne valeur:
N/A
Nouvelle valeur:
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor - The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information. | CWE-...
Total des modifications: 1 Dernière mise à jour: 3 months ago

> REFERENCES

https://cna.openjsf.org/security-advisories.html
https://github.com/nodejs/undici/security/advisories/GHSA-4cwx-7wf7-3272
« BACK_TO_HOME