> CVE-2024-51092

« BACK_TO_HOME
PUBLISHED
2026-05-08 06:16
MODIFIED
2026-05-08 06:16
EPSS (Prob. Exploit)
7.18%
Top 5.7%
DATA SOURCES:
NVD 🔗 2026-05-08 FIRST EPSS 🔗 2026-10-25 GITHUB 🔗 2026-10-29

> DESCRIPTION

LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().

> AFFECTED_PRODUCTS

ℹ️ Aucun produit affecté n'a encore été publié par NVD pour cette CVE.

> GITHUB SECURITY ADVISORY

GHSA-x645-6pf9-xwxw CRITICAL

LibreNMS has an Authenticated OS Command Injection

AFFECTED PACKAGES:
COMPOSER / librenms/librenms
<= 24.9.1
Fixed in: 24.10.0

> HISTORIQUE DES MODIFICATIONS

Première apparition
08/05/2026 06:16
Source: NVD
Total des modifications: 0 Dernière mise à jour: 6 months ago

> REFERENCES

https://github.com/librenms/librenms/security/advisories/GHSA-x645-6pf9-xwxw
https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exp...
« BACK_TO_HOME